Semarchy xDM System Requirements

Before installing Semarchy xDM, carefully examine the system requirements and certifications below to ensure compatibility with your environment.

Application Server

The Semarchy xDM server runs as a Java application in a supported application server, on physical or virtual machines.

Supported Java Versions

The Semarchy xDM application only supports Java 17 (LTS).

Java versions 8, 9, 10, 11, 12, 14, and 15 (non-LTS) are not supported.

The JAVA_HOME (for a JDK) or JRE_HOME (for a JRE) environment variable must be configured to point to a supported Java version.

Semarchy xDM supports the following Java runtime environments (JRE) or Java development kits (JDK):

  • OpenJDK

  • Microsoft Build of OpenJDK

  • Eclipse Temurin OpenJDK

  • Oracle JDK

  • Amazon Corretto (not supported for Apple M1 platforms)

Supported Application Servers

The Semarchy xDM application is certified with the following Apache Tomcat application server versions:

  • Apache Tomcat 9.0.x

As a JEE web application, Semarchy xDM may alternatively be installed on the following application servers:

  • Eclipse Jetty 10.x, 11.x, 12.x

  • Wildfly 27.x

Single deployment per application server instance

Because of its startup configuration mechanism, Semarchy xDM does not support multiple deployments within the same application server in a different context. For example, on the same Tomcat server, creating a http://host:80/semarchy/ deployment for production and a http://host:80/semarchy_test/ deployment for testing new releases is not supported.

Only one Semarchy xDM application may be deployed in each application server instance. In the previous example, each Semarchy instance must be deployed in a different Tomcat instance—​that is, http://host:80/semarchy/ for production and http://host:81/semarchy_test/ for testing new releases.

Memory Recommendations

The following recommendations apply to the application server tier:

  • The maximum memory allocation pool (-Xmx) of the Java virtual machine running the application server should be set to at least 4 Gb.

  • The operating system running the application server should have at least 8 Gb of RAM.

The hardware and software requirements depend on the application server. For more information, see your application server’s documentation.

Database Server

The Semarchy xDM repository and data locations are certified for the database engines and versions listed below.

Semarchy xDM discontinues support for a given database when that database reaches its end of life.

Oracle Database

Software versions

  • Version 21c

  • Version 19c

Editions

  • Express

  • Standard

  • Enterprise

Installation

  • Native, on-premises

  • Native, in the cloud

Supported platforms

PostgreSQL

Software versions

  • Version 14

  • Version 13

  • Version 12

    PostgreSQL version 12 is scheduled to reach its end of life in November 2024.

Installation

  • Native, on-premises

  • Native, in the cloud

Supported platforms

Starting from 2023.1.6, PostgreSQL version 11 is no longer supported (end of life). However, in line with Azure’s announcement of extended support for PostgreSQL 11 servers, Semarchy xDM will maintain its support for Azure Database for PostgreSQL 11 in Single Server until November 9, 2024.

Microsoft SQL Server

Software versions

  • SQL Server 2019 (version 15.0)

  • SQL Server 2017 (version 14.0)

Editions

  • Express

  • Standard

  • Enterprise

Installation

  • Native, on-premises

  • Native, in the cloud

Supported platforms

Memory Recommendations

The following recommendations apply to the database tier:

  • The machine running the database tier should have at least 4 CPUs and 16 Gb of RAM. Plan for more CPUs when using database parallelism.

  • For Oracle, the SGA size should be 8 Gb or above, depending on the number of records.

  • For PostgreSQL, the cache size should be 8 Gb or above, depending on the number of records.

The hardware and software requirements depend on the database server type, the number of records processed, and the type of processing performed in the database. For more information and tuning recommendations, see your database server’s documentation.

Client and Browsers

The browsers supported for the Semarchy xDM web user interfaces are listed below:

  • Google Chrome 68 and later (including Chrome for Android)

  • Firefox 61 and later, Firefox ESR 60 and later

  • Microsoft Edge 42 and later

  • Safari 11 and later (macOS and iOS)

Browser changes and automatic upgrades may introduce issues when working with Semarchy xDM. For the updated list of known issues on a specific browser or version, see the appropriate release notes.

License

A newly installed Semarchy xDM instance runs for a limited time—​the grace period—​without a license. Within that grace period, you should request an evaluation license from Semarchy to activate that instance.

When the grace period is over, the instance stops working: the applications, as well as the data stored in Semarchy xDM, are no longer available, and incoming data is no longer processed. The data stored in the hub is preserved as is.

For more information and detailed instructions on how to activate an instance and manage the license, see Manage the License.