Work with Projects

Resources in Semarchy xDI are organized into Projects and Folders.

Project Organization Example

You can organize your project folders as you want. A typical organization is as follows:

  • A top-level project folder.

    • A folder that holds metadata resources.

    • A folder that holds development resources.

      • A subfolder that holds processes.

      • A subfolder that holds mappings.

Create Projects

To create a project:

  1. Right-click in a blank area of the Project Explorer to open a context menu, or open the File menu to select menu:New[Project]. The New Project wizard opens.

  2. In the Wizards filter, enter Project, and then select the menu:General[Project] item in the tree view.

  3. Click Next.

  4. Enter a Project Name, and click Finish.

Create Folders

To create a project folder:

  1. In the Project Explorer, open the context menu for a project or an existing folder.

  2. Select menu:New[Folder]. The New Folder wizard opens.

  3. In the wizard, select the folder or project under which you want to create your folder.

  4. Enter a Folder Name and then click Finish.

You can drag and drop folders and resources, or use the Move action in a resource’s contextual menu.

The global project

The global project exists in all workspaces by default. It contains the following shared resources:

However, you can place your own resources inside this project.

Sample Projects

Semarchy xDI Designer comes with sample projects that demonstrate how to interface with certain technologies, and some of their use cases. These projects either come with the default installation, or get added when installing other components.

You can import sample projects from two places:

  • From the Welcome page (Help menu > Welcome): welcome page

  • When creating a project: select New in the File menu, then Example.